Incident

Incident with email sending

Resolved | Jun 24, 2025 | 11:55 GMT+01:00

The issue with email service has been resolved with all functions restored, while we continue to monitor the Swiftaid service, we will be resending any messages that failed during this period.

Resolution in progress | Jun 24, 2025 | 11:11 GMT+01:00

The issue sending email messages is resolved, we are actively restoring all email functions.

Identified | Jun 23, 2025 | 15:47 GMT+01:00

The Swiftaid service is currently unable to send Email messages, this is affecting login and account management operations.

Status Page powered by Admin Labs